Touch screen unresponsive

Faults and Technical chat for the Vauxhall Grandland
Post Reply
YorkshireLass
Posts: 2
Joined: Mon May 09, 2022 7:42 pm

Post by YorkshireLass » Wed May 11, 2022 12:36 pm

Touch screen on Navi5 intelilink suddenly unresponsive on whole screen. Tried cleaning it, checking fuses and disconnecting battery - no luck. Everything works fine by using the steering wheel to control what you can from there but the touch screen does not respond.

It’s a 2018 and we bought second hand from Vauxhall dealer in November 2021. Have today discovered there was a touch screen update available in April 2021, which was obviously not done prior to our purchase by either previous owner or dealer. No idea if this will sort it out. I’ve managed to download the update to USB ready but I’m not hopefully this will work as I understand from the help guide that you need to press “yes” on the screen to get it started.

Anyone had similar and solved the problem themselves?

I’ve seen there’s another thread with same issue and the chap was hopefully having dealer look at it on Monday 9th May. I’ve asked on there but he’s not been active and I can’t send message as not posted 5 times yet.

Any advice very much appreciated!

Thanks

Post Reply

  • You may also be interested in...
    Replies
    Views
    Last post